OCaml Forge

Detail: [#1213] if ocaml_version does not work.

Bugs: Browse | Download .csv | Monitor

[#1213] if ocaml_version does not work.

Date:
2012-09-03 17:11
Priority:
3
State:
Open
Submitted by:
Christophe Troestler (chris)
Assigned to:
Nobody (None)
Product:
OASIS
Due in version:
None
Resolution:
None
Severity:
normal
Version:
0.3.0~rc1
Component:
General
Operating System:
All
 
URL:
Summary:
if ocaml_version does not work.

Detailed description
The conditional

if ocaml_version(3.12.1)

does not work (oasis reports a syntax error).



A workatound for some cases is to do this in myocamlbuild.ml:
https://github.com/agarwal/ocamlweb/commit/f95a5556b744b9663cbef1fb912c92af35091529

Followup

Message
Date: 2015-08-17 00:00
Sender: Christophe Troestler

I hit that bug too. Actually, for the version, a more general value would be desirable: something like

if ocaml_version(> 3.12.1)

or

if ocaml_version > 3.12.1

Attached Files:

Changes:

No Changes Have Been Made to This Item