OCaml Forge

Detail: [#1196] Oasis-db's odb deps don't include XMETARequires deps

Bugs: Browse | Download .csv | Monitor

[#1196] Oasis-db's odb deps don't include XMETARequires deps

Date:
2012-08-05 04:00
Priority:
3
State:
Closed
Submitted by:
Edgar Friendly (thelema)
Assigned to:
Sylvain Le Gall (gildor-admin)
Product:
OASIS-DB
Due in version:
None
Resolution:
Won't Fix
Severity:
normal
Version:
0.3.0~rc1
Component:
None
Operating System:
None
 
URL:
Summary:
Oasis-db's odb deps don't include XMETARequires deps

Detailed description
pa_pipebang has the lines:

BuildDepends: camlp4.lib,
camlp4.quotations,
type_conv (>= 3.0.5)
XMETARequires: camlp4,type_conv,oUnit

in its _oasis file, but the deps for odb come out:

deps=type_conv(>=3.0.5),ocamlbuild,camlp4o,camlp4

Having a META require that's not a build require is odd, but I assume that since camlp4 is involved, it's legit. This issue requests that the XMETARequires dependencies be included in the odb deps.

Followup

No Followups Have Been Posted

Attached Files:

Changes:

Field Old Value Date By
status_idOpen2016-05-18 13:00chris
close_dateNone2016-05-18 13:00chris
ResolutionNone2016-05-18 13:00chris
assigned_tonone2012-09-03 13:13gildor-admin