OCaml Forge

Detail: [#890] oasis: check that findlib is working

Feature Requests: Browse | Download .csv | Monitor

[#890] oasis: check that findlib is working

Date:
2011-01-21 19:49
Priority:
3
State:
Open
Submitted by:
Török Edwin (edwin)
Assigned to:
Sylvain Le Gall (gildor-admin)
Resolution:
None
Due in version:
None
Product:
OASIS
Component:
None
Operating System:
None
 
Summary:
oasis: check that findlib is working

Detailed description
RHEL5 has old findlib (1.1.2), that doesn't support -modules (but the ocamldep installed does support it).
oasis generated build systems try to use -modules and fail.

If oasis always requires -modules, then maybe it should default to FindlibVersion: >= 1.2.0, or provide a workaround for older findlibs automatically.

Followup

No Followups Have Been Posted

Attached Files:

Changes:

Field Old Value Date By
assigned_tonone2011-01-31 09:37gildor-admin