OCaml Forge

Detail: [#1203] 0.4.1 does not build against OCaml 4.00.0

Bugs: Browse | Download .csv | Monitor

[#1203] 0.4.1 does not build against OCaml 4.00.0

Date:
2012-08-12 18:48
Priority:
3
State:
Closed
Submitted by:
Hezekiah Carty (hcarty)
Assigned to:
Christophe Troestler (chris)
Hardware:
None
Resolution:
Fixed
Severity:
normal
Version:
None
Component:
Cairo
Operating System:
None
Product:
Cairo
 
URL:
Summary:
0.4.1 does not build against OCaml 4.00.0

Detailed description
It is at least partially due to the older version of oasis used to generate its build scripts. However, running "oasis setup" in a freshly unpacked source directory still leaves other problems.

Followup

Message
Date: 2013-08-08 20:33
Sender: Christophe Troestler

I tried with OCaml 4.00.1 and it compiles fine.
Date: 2013-06-15 12:10
Sender: Christophe Troestler

I have released version 0.4.3. https://forge.ocamlcore.org/frs/?group_id=246 Please let me know whether it solves your problem.
Date: 2012-09-14 11:47
Sender: Hezekiah Carty

The attached patch against master allowed these bindings to compile and install under my OCaml 4.00.0 install.

Attached Files:

Attachments:
fix-ocaml-4.00.0-install.patch

Changes:

Field Old Value Date By
ResolutionNone2013-08-08 20:33chris
status_idOpen2013-08-08 20:33chris
close_dateNone2013-08-08 20:33chris
assigned_tonone2013-06-15 12:10chris
File Added192: fix-ocaml-4.00.0-install.patch2012-09-14 11:47hcarty