OCaml Forge

Detail: [#857] default theme not refreshed after fusion forge upgrade

Bugs: Browse | Download .csv | Monitor

[#857] default theme not refreshed after fusion forge upgrade

Date:
2011-01-02 09:40
Priority:
3
State:
Open
Submitted by:
Stefano Zacchiroli (zack-admin)
Assigned to:
Sylvain Le Gall (gildor-admin)
Host:
forge.ocamlcore.org
Forwarded Upstream:
None
Summary:
default theme not refreshed after fusion forge upgrade

Detailed description
After the upgrade to fusion forge, I've noticed *no* change to the default theme on forge.o.o
Only now I've discovered that I see no changes only if I'm logged in, while if I'm not I do see the new brown-ish theme.

In my preferences the chosen theme was "Default Theme" and I expected that choice to be automatically bumped to the new theme. Apparently this is not the case and, to see the new theme while logged in, I had to choose *explicitly* (which is unfortunate) "OCaml Forge Official Theme" from the list.

Cheers.

Followup

Message
Date: 2011-01-03 16:00
Sender: Sylvain Le Gall

I agree with Mehdi. The intermediate solution is to display a form asking user if he wants to change his theme and do it automatically. This could be done at login for example and only once.
Date: 2011-01-02 11:15
Sender: Mehdi Dogguy

Well, I don't find that unfortunate. Usually, it's not a good idea to overwrite user's configurations, IMO. I think It's best to not blindly enforce the theme for all users.

Attached Files:

Changes:

Field Old Value Date By
assigned_tonone2011-01-03 16:00gildor-admin