OCaml Forge

Detail: [#690] OASIS configure use setup.data

Bugs: Browse | Download .csv | Monitor

[#690] OASIS configure use setup.data

Date:
2010-07-24 09:48
Priority:
3
State:
Open
Submitted by:
Sylvain Le Gall (gildor-admin)
Assigned to:
Sylvain Le Gall (gildor-admin)
Product:
OASIS
Due in version:
None
Resolution:
None
Severity:
None
Version:
0.1.0
Component:
OASIS
Operating System:
None
 
URL:
Summary:
OASIS configure use setup.data

Detailed description
For example,

setup.data contains an old version of ocaml_version variable.

./configure runs 'ocamlc -config' but uses the predefined variable.

$ ./configure --prefix ~/programmation/00build/ocaml-3.11.2-linux-amd64/
I: Running command '/usr/bin/ocamlc -config > /tmp/oasis-16c8c6.txt'
W: Field 'ocaml_version_ge_3_11_0' is not set: Cannot satisfy version constraint on ocaml: >= 3.11.0 (version: 3.10.2)
I: Running command '/usr/bin/ocamlfind query -format %d pcre > /tmp/oasis-a7d9bb.txt'
E: OCaml version 3.10.2 doesn't match version constraint >= 3.11.0
E: 1 configuration error

$ ocamlc -config
version: 3.11.2
standard_library_default: /usr/lib/ocaml
standard_library: /usr/lib/ocaml
standard_runtime: /usr/bin/ocamlrun

$ grep ocaml_version setup.data
ocaml_version = "3.10.2"
ocaml_version_ge_3_10_2 = "3.10.2"

A simple distclean is enough to solve this error.

Followup

No Followups Have Been Posted

Attached Files:

Changes:

No Changes Have Been Made to This Item