OCaml Forge
SCM

Detail: [#1175] emacs21: void-function tuareg-before-change-function

Bugs: Browse | Download .csv | Monitor

[#1175] emacs21: void-function tuareg-before-change-function

Date:
2012-06-14 19:45
Priority:
3
State:
Closed
Submitted by:
Ralf Treinen (treinen)
Assigned to:
Nobody (None)
Hardware:
None
Resolution:
Won't Fix
Severity:
None
Version:
None
Component:
None
Operating System:
None
Product:
None
 
URL:
Summary:
emacs21: void-function tuareg-before-change-function

Detailed description
Debian user Kevin Ryde <user42@zip.com.au> reports message

void-function tuareg-before-change-function

obtained with emacs21. He adds:

tuareg-mode has

(unless tuareg-use-syntax-ppss
(add-hook 'before-change-functions 'tuareg-before-change-function nil t))

but doesn't seem to define a `tuareg-before-change-function'.

This only affects emacs21 where there's no `syntax-ppss'. I presume
tuareg.el is more or less meant to work without syntax-ppss, in as much
as the code in several places checks tuareg-use-syntax-ppss. But I
can't tell what this before-change might be meant to be.

Followup

Message
Date: 2013-08-16 12:57
Sender: Christophe Troestler

Emacs 21 is more than 10 years old. Why can't your user upgrade? If he does not want, he can always also use a old version of tuareg.

Attached Files:

Changes:

Field Old Value Date By
status_idOpen2014-01-02 12:54chris
close_dateNone2014-01-02 12:54chris
ResolutionNone2013-08-16 12:57chris