OCaml Forge
SCM

Detail: [#1172] emacs21: needs (require 'derived)

Patches: Browse | Download .csv | Monitor

[#1172] emacs21: needs (require 'derived)

Date:
2012-06-12 19:18
Priority:
3
State:
Closed
Submitted by:
Ralf Treinen (treinen)
Assigned to:
Christophe Troestler (chris)
Resolution:
Accepted
Version:
None
Component:
None
 
Summary:
emacs21: needs (require 'derived)

Detailed description
Sent in by debian user Kevin Ryde <user42@zip.com.au>:

I've still got emacs21 installed and tuareg-mode 2.0.6 fails to install
with

While compiling toplevel forms in file
+/usr/share/emacs21/site-lisp/tuareg-mode/ocamldebug-tuareg.el:
!! Symbol's function definition is void ((derived-mode-p))

This seems to happen only with GNU emacs 21.

The attached patch fixes this. -Ralf.


Followup

Message
Date: 2013-02-18 19:35
Sender: Christophe Troestler

I have fixed it but you may have problems with the newer SMIE mode — not used yet by default.

Attached Files:

Attachments:
emacs21

Changes:

Field Old Value Date By
status_idOpen2013-02-18 19:35chris
close_dateNone2013-02-18 19:35chris
ResolutionNone2013-02-18 19:35chris
assigned_tonone2013-02-18 19:35chris
File Added181: emacs212012-06-12 19:18treinen